Inicio > Ubuntu facil, Utilidades > Ubuntu facil – Como saber que version de kernel estamos usando

Ubuntu facil – Como saber que version de kernel estamos usando

Abres una terminal (Aplicaciones/Accesorios/Terminal) pones “uname -r” y ejecutas…quedando algo asi:

Imagen terminal

en este caso la version es “2.6.17″ la revision “10″ y “generic” seria la arquitectura del procesador…

 



Volver al indice


Como?

About these ads
Categorías:Ubuntu facil, Utilidades
  1. Cesar
    3 abril, 2007 en 21:02 pm | #1

    Eso esta bien, pero tengo una duda, en el grub, cuando arranco mi maquina aparecen varios kernell de arranque, la version 2.6.17.10 y la 2.6.17.11, tanto en generic como en recovery, quisiera eliminar la .17.10 ya que siempre uso la 17.11 como podria hacerlo?

  2. Chili-Cuil
    23 abril, 2007 en 2:29 am | #2

    Cesar

    Lo único que necesitas tipear es:

    apt-get remove –purge linux-image-2.6.17-11-generic (suponiendo que posees esta arquitectura)…

    Esta instrucción tambien quitara la entrada del grub.

  3. Artruo
    23 mayo, 2007 en 22:02 pm | #3

    Hola, disculpa si la pregunta tonta pero en la pagina de ubuntu packages aparecen todas estas versiones de ubuntu:
    * warty
    * hoary
    * hoary-backports
    * breezy
    * breezy-backports
    * dapper
    * dapper-backports
    * edgy
    * edgy-backports
    * feisty
    * feisty-backports
    * gutsy

    Yo recibi el disco de Ubuntu y es la version 6.10, com puedo saber cual es mi version por nombre. Aqui en el titulo de este tema dice así “Ubuntu facil – Como saber que version de kernel estamos usando (Edgy 6.10)” por lo que por logica como yo tambien tengo la version 6.10 tengo Egdy, pero como le hago para saber que noes Feisty por ejemplo.

    Gracias

  4. acritarca
    29 mayo, 2007 en 1:30 am | #4

    yo tengo el mismo problema y cuando doy esas instrucciones en consola me pone lo siguiente:
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo información de estado… Hecho
    E: No se pudo encontrar el paquete –purge

  5. tirso
    15 junio, 2007 en 5:43 am | #5

    ES posible montar una vpn utlizando solo el protocolo l2tp en alguna version de ubuntu

  6. david
    21 junio, 2007 en 16:15 pm | #6

    al igual que cesar a mi me sucede lo mismo….””en el grub, cuando arranco mi maquina aparecen varios kernell de arranque, la version 2.6.17.10 y la 2.6.17.11, tanto en generic como en recovery, quisiera eliminar la .17.10 ya que siempre uso la 17.11 como podria hacerlo?””lo que pasa es q soy muy novato en ubuntu apenas llevo 2dias conociendo el sistema y no se a que se refieren con tipear….agradezco sus respuestas

  7. 21 junio, 2007 en 16:23 pm | #7

    david,
    puedes desinstalar los kernels antiguos de forma grafica desde el gestor de paquetes sinaptic, de todas formas, yo te recomendaria que dejes los dos ultimos por si tienes algun problema .. ;)

  8. Balu
    6 julio, 2007 en 15:25 pm | #8

    Puedes tambien editar en el archivo ‘/boot/grub/menu.lst’ poniendo ‘#’ en cada version del kernel que no quieres que aparezca, en una terminal escribe ‘sudo gedit /boot/grub/menu.lst’ o ‘sudo kate /boot/grub/menu.lst’ si tienes kubuntu, te pedira tu passw puesto que necesitas permisos de superusuario (sudo = SUperuser DO), en ese archivo despues de la liniea que diga ‘## ## End Default Options ##’ comenta (pon un ‘#’ al principio de la linea) una por una las lineas del kernel que no quieres que aparezca en tu menu, de preferencia deja la primera y la tercera opcion de estos, asi ocupas tu versio del kernel mas reciente y tienes una opción por si no arranca, tambien puedes comentar la prueba de memoria ‘memtest86+’ con sus respectivas lineas y en ‘title’ puedes cambiar el nombre de tu nucleo o agregar algunas lienas de referencia, ejemplo:

    title Debian GNU/Linux, kernel 2.6.20-16-generic ACTUAL
    root (hd0,3)
    kernel /boot/vmlinuz-2.6.20-16-generic.rej root=/dev/hda4 ro quiet splash
    boot

    #title Debian GNU/Linux, kernel 2.6.20-16-generic (recovery mode)
    #root (hd0,3)
    #kernel /boot/vmlinuz-2.6.20-16-generic.rej root=/dev/hda4 ro #single
    #boot

    title Debian GNU/Linux, kernel 2.6.17-11 ESTABLE
    root (hd0,3)
    kernel /boot/vmlinuz-2.6.17-11-generic root=/dev/hda4 ro quiet splash
    initrd /boot/initrd.img-2.6.17-11-generic
    boot

    #title Debian GNU/Linux, kernel 2.6.17-11-generic (recovery mode)
    #root (hd0,3)
    #kernel /boot/vmlinuz-2.6.17-11-generic root=/dev/hda4 ro single
    #initrd /boot/initrd.img-2.6.17-11-generic
    #boot

    title Debian GNU/Linux, kernel 2.6.17-10-generic.rej
    root (hd0,3)
    kernel /boot/vmlinuz-2.6.17-10-generic.rej root=/dev/hda4 ro quiet splash
    boot

    #title Debian GNU/Linux, kernel 2.6.17-10-generic (recovery mode)
    #root (hd0,3)
    #kernel /boot/vmlinuz-2.6.17-10-generic.rej root=/dev/hda4 ro #single
    #boot

    #title Debian GNU/Linux, kernel memtest86+
    #root (hd0,3)
    #kernel /boot/memtest86+.bin
    #boot

    ### END DEBIAN AUTOMAGIC KERNELS LIST

    # This is a divider, added to separate the menu items below from the Debian
    # ones.
    title Other operating systems:
    root

    # This entry automatically added by the Debian installer for a non-linux OS
    # on /dev/hda1
    title Microsoft Windows XP Home Edition
    root (hd0,0)
    savedefault
    makeactive
    chainloader +1

    Asi podria quedar, de esta forma no borras tus versiones que tienes y te evitas el problema de lamentarte por eliminar algo que te puede servir en caso de que no arranque tu sistema y recuperar el estable, para hacer esto en un sistema que no arranque en modo grafico dentro de tu sesion en modo shell o tipo “ms-dos” tecleas o “tipeas” ‘sudo vim /boot/grub/menu.lst’ y descomentas las lineas de tu kernel que te pueden servir a solucion del problema.
    saludos

  9. jim
    19 septiembre, 2007 en 2:53 am | #9

    Artruo, igual que tu, yo estaba buscando lo mismo (apenas estoy aprendiendo linux), saber que version por nombre estoy corriendo, puedes hacer lo siguiente: abre el archivo etc/apt/sources.list con un editor de texto y te aparece un listado de sitios para bajar repositorios, pero de acuerdo a tu version debe estar escrito el “nombre” con que se identifica el Ubuntu que estas corriendo. Suerte

  10. 6 octubre, 2007 en 2:51 am | #10

    Sencillo camaradas, visiten esta página y vayan al capítulo de lanzamientos, donde encontrarán tanto los lanzamientos (por versión y por nombre) que ha habido, como el sistema que se usa:

    http://es.wikipedia.org/wiki/Ubuntu_(distribuci%C3%B3n_Linux)

  11. anibal3
    8 noviembre, 2008 en 18:56 pm | #11

    Perdon pero recien estoy aprendiendo esto. Cuáles on los pasos para abrir un terminal y ver el kernell que tengo. Gracias

  12. 30 noviembre, 2008 en 20:03 pm | #12

    Para saber la versión de Ubuntu “con nombre” y no la del Kernel

    lsb_relasee -a

  13. 20 febrero, 2009 en 23:20 pm | #13

    Que tal amigos…. si apoyando un poco también pueden escribir desde consolo y como root

    lsb_release -a

    lo que dara como resultado esto:
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 8.10
    Release: 8.10
    Codename: intrepid

    o puedes tratar con:
    uname -r un detalle genérico
    uname -a un detalle con mas datos
    cat /etc/lsb-release

    Saludos desde Guatemala.

  14. Carlos
    3 septiembre, 2010 en 15:08 pm | #14

    No se ve la imagen, lo hubieran puesto como texto.

  15. yoyo
    29 mayo, 2011 en 19:44 pm | #15

    Ayuda quiero quiero instalar el ubuntu 6.10 a una hp mini desde usb corre desde la usb pero no muestra el entorno grafico pienso que talvez el kernel tre los driver de video es 954gme pero ubuntu 6.10 medice que es i810 bueno mejor decidi actualizar el kernel para que reconociera el video pero no se como actuelizarlo auna vercion mas reciente aunque sea la de ubuntu 10.04 me pueden ayudar a actualizar

  16. jesus daniel
    9 diciembre, 2011 en 22:07 pm | #16

    amigos me super urge poder activar mi wifi tengo linux mint 12 y ubuntu 10.10 instalados y ninguno lo detecta. ejecute madwifi pero me dice que mi kernel no es compatible

  1. No trackbacks yet.

Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Seguir

Recibe cada nueva publicación en tu buzón de correo electrónico.

Únete a otros 37 seguidores

%d personas les gusta esto: